우분투 14.04 LTS 에서는 vsftp 3.0.2 가 설치되어 있다.


구글링을 해봐도 vsftpd 2.3의 버그라고 하면서 3.0.2 를 설치하라고 한다 -_-;


이미 3.0.2 버전임에도 500 OOPS: vsftpd: refusing to run with writable root inside chroot() 이 오류가 나온단 말이지..


또 다시 구글링!


그리고 찾아낸 방법


일단 chroot 관련 설정을 사용하면 위 오류가 발생한다.


각 사용자 별로 상위 디렉토리 이동을 막고 싶을때는 다음과 같이 설정 한다.


chroot_list_enable=YES
chroot_list_file=/etc/vsftpd.chroot_list
allow_writeable_chroot=YES
seccomp_sandbox=NO



allow_writeable_chroot 와 seccomp_sandbox=NO 를 설정하면 정상적으로 로그인 된다.




저작자 표시 비영리 변경 금지
신고
Tag

다른 카테고리의 글 목록

강좌/HP N54L 활용 카테고리의 포스트 목록